OpenRoads Designer CONNECT Edition SDK Help

StrokeByStep(Double, StrokingByStepMethod, LinearPointCollection) Method

Strokes linear element by step.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearPointCollection StrokeByStep(double stepValue, StrokingByStepMethod method, LinearPointCollection linearPoints)

Parameters

SettingDescription
   Incremental/equal step distance.
  StrokingByStepMethod Stroking by step method.
  LinearPointCollection Initial linear point collection.

Return Value

LinearPointCollection Collection of stroked points.

Remarks

The points are added to the initial point collection. This method allows creating a collection of points along a curve with different criteria and apply them consecutively. The order in which the stroking is applied determines the priority of one of the criteria.

See Also